站外题求hack or debug
  • 板块灌水区
  • 楼主louie2011
  • 当前回复0
  • 已保存回复0
  • 发布时间2025/2/7 16:49
  • 上次更新2025/2/7 19:35:40
查看原帖
站外题求hack or debug
941801
louie2011楼主2025/2/7 16:49

玄关

题目:悲剧文本

You’re typing a long text with a broken keyboard. Well it’s not so badly broken. The only problem
 with the keyboard is that sometimes the “home” key or the “end” key gets automatically pressed
 (internally).
 You’re not aware of this issue, since you’re focusing on the text and did not even turn on the
 monitor! After you finished typing, you can see a text on the screen (if you turn on the monitor).
 In Chinese, we can call it Beiju. Your task is to find the Beiju text.
 Input
 There are several test cases. Each test case is a single line containing at least one and at most 100,000
 letters, underscores and two special characters ‘[’ and ‘]’. ‘[’ means the “Home” key is pressed
 internally, and ‘]’ means the “End” key is pressed internally. The input is terminated by end-of-file
 (EOF).
 Output
 For each case, print the Beiju text on the screen.
 Sample Input
 This_is_a_[Beiju]_text
 [[]][][]Happy_Birthday_to_Tsinghua_University
 Sample Output
 BeijuThis_is_a__text
 Happy_Birthday_to_Tsinghua_University

代码:

#include<bits/stdc++.h>
using namespace std;
string str;
char arr[100050];
int nxt[100050];
int main()
{
	while(cin>>str)
	{
		int len=str.length();
		int ptr=0;
		int last=0;
		int blank=2;
		nxt[0]=1;
		for(int i=0;i<len;i++)
		{
			if(str[i]=='[')
			{
				ptr=0;
			}
			else if(str[i]==']')
			{
				ptr=last;
			}
			else
			{
				nxt[blank]=nxt[ptr];
				nxt[ptr]=blank;
				arr[blank]=str[i];
				blank++;
				if(ptr==last)
				{
					last=nxt[ptr];
				}
				ptr=nxt[ptr];
			}
		}
		int tmp=0;
		while(tmp!=1)
		{
			cout<<arr[nxt[tmp]];
			tmp=nxt[tmp];
		}
		cout<<endl;
	}
	return 0;
}
2025/2/7 16:49
加载中...